queue  45
support
Results 1 to 7 of 7

Thread: OneUp Blog - Masonry Boxed post count on page load

  1. #1

    OneUp Blog - Masonry Boxed post count on page load

    This feels like a really dumb question but I've looked everywhere and can't find the answer. On our new blog page: http://overabove.com/blog
    Only 3 posts load in when the page loads, then the Load More button loads in the next set.

    On my Settings > Reading page, this is set to 10 "Blog pages show at most"

    I can't find anything that is limiting this initial load to 3 posts, and I'd like to bump it up to 6.

    Any ideas? Thanks in advance!

  2. #2
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    2,078
    Hi, It depends on how you have made the blog.

    To make a blog block you make a "view" first. Main admin menu -> Views.

    In there you select posts as input data and then under "show data as" you select "blog".

    In this area you can now choose the max number of posts to be shown, set if you want to use the load more button etc.

    So if your existing blog section is made this way, the setting you are looking for will be in there, but if its made in a different way, it could be elsewhere.

    Could you give me some more info about your blog? Check the view which makes up your blog or the grid etc. then look for a "Max" field.

  3. #3
    Thanks for the reply. I checked the settings. The view is called "Blog Masonry Boxed."
    In that view, the Data Type is set to Gallery.
    Display Gallery as Slider - Volo (swipe)

    On the page itself where I'm telling the page what view to use, I've selected Blog Masonry Boxed. I can't see anything anywhere for a Max field.

    I wish I had more info on this. Someone else built this and I'm just trying to tweak this one setting. Have I provided any details that help?

  4. #4
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    2,078
    Hi, Are you sure? Because the content for that view is not a gallery but are posts, and it's rendered (output) as a masonry portfolio grid, so it can't be set to a slider like you have mentioned in your post. You are probably not checking the correct "view". Once you find the right "view" your will see the Max field as I described above. Check all your views if you need to.

  5. #5
    I attempted to make a new view for this so I'm starting from scratch. Oddly, in my Data Type dropdown, "Posts" is not an option. Under the subhead of "Post-Based" I only see the options:
    Pages
    Media
    Themes
    Contact Forms
    Videos
    Projects
    Staff Members
    Services
    Testimonials
    Slides

    Any idea why I don't have an option for Posts?

  6. #6
    I searched through your forum here and saw other people with the same problem - Posts, as a data type missing when creating a view. It seemed the common suggestion was to disable plugins. So, I started disabling one at a time and found the Google Analytics by Monster Insights plugin was the culprit. With that disabled (and the GA code infused elsewhere), I now have the Posts data type back and have my view set up properly, and I can now control how many posts load on the initial load.

  7. #7
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    2,078
    Glad to hear its sorted.