queue  6
support
Results 1 to 9 of 9

Thread: Mixed Content is preventing the page to show secure badge (SSL)

  1. #1
    Junior Member
    Join Date
    Jun 2014
    Posts
    9

    Mixed Content is preventing the page to show secure badge (SSL)

    Hey, pixelentity team.

    Recently we upgraded one of the websites using One Up to use SSL. After changing all the URL's from HTTP to https, we're still getting an error on the homepage saying that we loaded a stylesheet over HTTP.

    We double checked that all additional files that we created being loaded over https were changed to https, so we think the problem is on your end.
    Take a look at the console and try to figure out whats preventing the page from being fully secured.
    We are aware that some Youtube videos thumbnails are being served over HTTP but that's also a problem on your end since we don't control how these videos are embedded in the page.

    The website is https://academiaaki.pt.

    Also, after upgrading to SSL, sometimes the logo on the splash section is shifted to the right (happening in FULL HD screens).

    Please take a look at the issues described.
    Thanks in Advance,

    Spark Agency

  2. #2
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    Hi, Have you change the http to https in wp-content/themes/oneup/framework/js/pe/jquery.pixelentity.utils.youtube.js ? Also make sure once you do this that you disable js compression in the theme options panel, advanced tab.

  3. #3
    Junior Member
    Join Date
    Jun 2014
    Posts
    9
    Hey Donagh.

    I do confirm that I have changed the http to https in wp-content/themes/oneup/framework/js/pe/jquery.pixelentity.utils.youtube.js.
    JS Compression is also turned off.

    I went in to an incognito tab in Chrome but the green padlock is not there yet, so, the page is still serving HTTP content.
    Please, take a look at the page and go to the console for further details.
    The website is https://academiaaki.pt

  4. #4
    Junior Member
    Join Date
    Jun 2014
    Posts
    9
    Hey Donagh,

    Any update on these HTTP/HTTPS problems? We're paying an SSL certificate but our site does not show it is secure because of the Youtube thumbnails being served over HTTP.
    Also, the logo that appears in the splash section is not centred on mobile. Can you take a look, please!?

    Thanks in advance.

  5. #5
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    Hi,

    Sorry for the delay check the following file:

    wp-content/themes/oneup/framework/js/pe/jquery.pixelentity.videoPlayer.js

    On line 78 you will see the following:

    Code:
    var posters = {
    			vidly: "http://cf.cdn.vid.ly/$ID/poster.jpg",
    			youtube: "http://img.youtube.com/vi/$ID/0.jpg",
    			vimeo: "http://vimeo.com/api/v2/video/$ID.json?callback=?"
    		};
    You should change the http to https in the youtube part, this should be the code which control the loading of the thumbnails for the youtube videos. Again, make sure the js compression option is disabled in the theme options panel, advanced tab.

  6. #6
    Junior Member
    Join Date
    Jun 2014
    Posts
    9
    Hey Donagh.

    I can confirm that those changes to the file have made the Youtube thumbnails to be served over HTTPS. It's working now.
    I also had to turn off the JS compression.

    Another question, the logo on the splash section that appears when I enter the website is shifted to the right, do you know whats happening? Can you help me fix that too?
    The website is https://academiaaki.pt

  7. #7
    Hi diogobarros,

    Saw your thread about the logo on the splash section shifting right - I was having the same issue and fixed the problem as per this thread.

    http://support.pixelentity.com/threa...hlight=shifted

  8. #8
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    Looks to me that your logo issue has been fixed. Would that be correct? Os it this still a problem?

  9. #9
    Junior Member
    Join Date
    Jun 2014
    Posts
    9
    Hey Donagh.

    I can confirm that the code found on the thread linked by MarkBarrett.ca a few comments above solved my issues with the logo positioning.
    Everything is fine now. Thanks for all the support.