queue  7
support
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: [SOLVED] scrolling stopped working on Chrome

  1. #1
    Junior Member
    Join Date
    Sep 2017
    Posts
    6

    scrolling stopped working on Chrome

    Iím developing a website using Visia, Iíve created a child theme, everything was working fine, then the smooth scroll stopped working, only on Chrome v61. It works fine on Safari and Firefox. It works for the Contact link once, then it stops working. The other two links I have, Services and Work, no longer scroll down/up to those sections. Scrolling up using the Home link works. I searched the forum, but did not find any threads with this particular issue. I tried switching back to the parent theme, but that didnít work. Can you please help me troubleshoot this issue? Thank you.

    ** Hidden Content: You don't have sufficient privileges to see this hidden data **

  2. #2
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    Hi, Yes this looks to be caused by something in the Chrome update, I'm still investigating the issue for a fix. Thanks for your patience.

  3. #3
    Junior Member
    Join Date
    Sep 2017
    Posts
    6
    Okay, thank you for your reply.

  4. #4
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    Hi, I've found the problem.

    1. Go here: https://github.com/flesler/jquery.localScroll

    2. Click clone or download > download zip > unzip and grab this file: "jquery.localScroll.js" and place it onto your server inside the following folder:

    "visia(theme folder) > js" (you will need to replace the existing one which is there).

    3. Then navigate to your WP admin > appearance > theme options > advanced (tab) and disable js compression.

    4. Save and that should be it.

  5. #5
    Junior Member
    Join Date
    Nov 2013
    Posts
    9
    Hi Donagh,

    I'm having the same issue with Chrome. I tried your fix but it messes up the website (elements out of place, images missing, etc.).
    My site - http://wyattvisuals.com/
    Thoughts?

  6. #6
    Junior Member
    Join Date
    Sep 2017
    Posts
    6
    Hi Donagh, I followed your instructions, but it is still not working. Can you please take a look. Thank you

  7. #7
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    @vantime I've checked your site and you're still loading version 1.2.7 of that script so you have not followed the instructions above correctly. It should be version 2.

  8. #8
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,946
    @rexiars Your script is version 2 - the correct one and the scrolling is working fine on your site as I see. Maybe clear your cache if its not working for you yet.

  9. #9
    Junior Member
    Join Date
    Sep 2017
    Posts
    6
    Quote Originally Posted by Donagh View Post
    @rexiars Your script is version 2 - the correct one and the scrolling is working fine on your site as I see. Maybe clear your cache if its not working for you yet.
    Yes, it works now, but there was additional things I had to do:
    Turns out you also have to download and replace jquery.scrollTo.js http://github.com/flesler/jquery.scrollTo. And change the name from "jquery.scrollTo.js" to "jquery.scrollto.js" - lowercase t or it won't work.

    Smooth scroll/anchor links are now working again. Thank you

  10. #10
    Junior Member
    Join Date
    Nov 2013
    Posts
    9
    Quote Originally Posted by Donagh View Post
    @vantime I've checked your site and you're still loading version 1.2.7 of that script so you have not followed the instructions above correctly. It should be version 2.
    Thanks Donagh. Yes, I had to swich it back as version 2.0 had my site all messed up. However, the solution for me was the upload the 2.0 version of the scroll master file, and make sure the 'S' in 'jquery.localScroll' is changed to lowercase. And, I also had to follow rexiars advice about getting the scrollTo file and making sure it is renamed with lowercase 'T' as well.

    Thanks!