queue  5
support
Results 1 to 4 of 4

Thread: Brandspace Contact Page and Maps not working

  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    10

    Brandspace Contact Page and Maps not working

    Noticed today that our Contact page is having several issues and I don't know what changed, but it was working originally. Here are the issues:

    - The map location is not working. Saying to see the JavaScript console for technical details. Don't know what this is referring to, or why it is happening.
    - We have the field data for submitting a message which seems to allow a message to be typed, but I don't know where the Submit Form button sends the email to.
    - I have text posted above the information on the screen that for some reason is not showing up.

    The page is http://studioarchitects.us/contact/

    The page this was based on is http://www.dadot.com/atlanta-contact/

    There is an available update to the Brandspace template, but I have not done this at the present time. thanks!

  2. #2
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,918
    Hi, You need to create and insert an api key for the google maps use on your website, Google made this change to their API rules quite some time ago. The solution for your theme can be found in this thread: http://support.pixelentity.com/threa...ht=google+maps

    Once this error is fixed, the other stuff should work also. If not post again and I'll check then.

  3. #3
    Junior Member
    Join Date
    Dec 2016
    Posts
    10
    Quote Originally Posted by Donagh View Post
    Hi, You need to create and insert an api key for the google maps use on your website, Google made this change to their API rules quite some time ago. The solution for your theme can be found in this thread: http://support.pixelentity.com/threa...ht=google+maps

    Once this error is fixed, the other stuff should work also. If not post again and I'll check then.
    I went to the link you posted and read through it. I downloaded the file but there are several locations in the structure where this file occurs. I did not apply the theme to our website, it was done by our IT department that we sub-contract to. I did edit the JS file as indicated and tried to upload it, but it doesn't appear to be working. I am getting errors when trying to upload the file using CuteFTP. I am wondering if it is a permissions thing on the files set by my IT Group, and I am checking with them. But I don't know if I am also trying to upload the file in the correct place either. Thanks!

  4. #4
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    1,918
    Hi, You'll need to put it back in the exact place where it was overwriting the original file in the process. If you are not sure about carrying out this step, then we recommend that you seek help with this because if you overwrite the wrong file you could ruin your install of WordPress.