queue  12
support
Results 1 to 2 of 2

Thread: Problems in Code lead to translation errors

  1. #1

    Problems in Code lead to translation errors

    I am trying to translate the theme to german. When I use poedit as requested the whole back-end ends in a terrible "denglish". So I tried to translate the page with CodeStyling Localization only to see that there are many code errors resulting in an untranslatable theme:


    DEPRECATED Error: [8192] Assigning the return value of new by reference is deprecated /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/boot.php on line 35
    DEPRECATED Error: [8192] Assigning the return value of new by reference is deprecated /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/PeGlobal.php on line 72
    DEPRECATED Error: [8192] Assigning the return value of new by reference is deprecated /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/PeTheme/PeThemeGallery.php on line 554
    STRICT Error: [2048] Only variables should be assigned by reference /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/theme/php/PeTheme/PeThemeSurreal.php on line 584
    STRICT Error: [2048] Only variables should be assigned by reference /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/PeTheme/Constant/PeThemeConstantGallery.php on line 9
    STRICT Error: [2048] Only variables should be assigned by reference /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/PeTheme/Constant/PeThemeConstantVideo.php on line 13
    DEPRECATED Error: [8192] Assigning the return value of new by reference is deprecated /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/PeTheme/PeThemeData.php on line 15
    DEPRECATED Error: [8192] Assigning the return value of new by reference is deprecated /home/MYUSER/[MYDOMAIN]/wp-content/themes/surreal/framework/php/PeTheme/PeThemeData.php on line 68


    Is there any way to fix this so i can completely translate the theme to German?

    Thanks in advance

  2. #2
    Lead Coder Fabio's Avatar
    Join Date
    Aug 2011
    Posts
    2,081
    Hello,

    easier solution would be to turn WP_DEBUG off

    https://codex.wordpress.org/Debugging_in_WordPress
    My cave is full of servers