queue  35
support
Results 1 to 3 of 3

Thread: [SOLVED] Firefox not showing font graphics

  1. #1
    Junior Member
    Join Date
    May 2017
    Posts
    2

    Firefox not showing font graphics

    I really love this theme and have spent a lot of time setting it up. I recently added SSL and have overcome some of the issues with https settings. One remaining problem I am trying to fix is Firefox not showing font icons when using HTTPS.

    Check out my site: https://newleafcreatives.com

    When using Firefox none of the font icons are visible but are replaced with a default symbol. Same for the social icons on the footer. This does not happen with Safari.

    Without SSL applied to the site both Firefox and Safari work perfectly. I was having a similar problem with Youtube and made a change to theme.min.js for https and that fixed the problem. Is there such a setting for font icons?

    Thanks.

  2. #2
    Lead Coder Fabio's Avatar
    Join Date
    Aug 2011
    Posts
    2,081
    Hello,

    i get the following error

    Code:
    Access to Font at 'https://www.newleafcreatives.com/wp-content/themes/smartmvp/assets/fonts/ElegantIcons.ttf' from origin 'https://newleafcreatives.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://newleafcreatives.com' is therefore not allowed access.
    for all the icon fonts. Check this link for a possible solution http://stackoverflow.com/questions/1...rigin/17110999
    My cave is full of servers

  3. #3
    Junior Member
    Join Date
    May 2017
    Posts
    2
    AWESOME!!!

    The link you provided led to a fix for the font icon using SSL problem I was experiencing. I'm all set now.

    Great support and prompt too.

    Many thanks