queue  45
support
Results 1 to 8 of 8

Thread: Portfolio not showing on https://

  1. #1
    Junior Member
    Join Date
    Dec 2015
    Posts
    8

    Portfolio not showing on https://

    I can't see the portfolio when I'm viewing this on https ... assuming it's because they are being served with http hard-coded into image links? Is there a way to fix?

  2. #2
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hi,

    can you please share your website url and we will take a look.

    Thanks

  3. #3
    Junior Member
    Join Date
    Dec 2015
    Posts
    8
    of course, sorry...

    fourfincreative.com

  4. #4
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hi,

    looks like the image resizing is not working. Did the portfolio section work on the same server before switching to https?

    I think it's due to the GD image library (a php extension) not being installed or enabled. If you could contact the hosting provider and ask them about it, it should be a quick task for them.

  5. #5
    Junior Member
    Join Date
    Dec 2015
    Posts
    8
    Quote Originally Posted by Ante View Post
    Hi,

    looks like the image resizing is not working. Did the portfolio section work on the same server before switching to https?

    I think it's due to the GD image library (a php extension) not being installed or enabled. If you could contact the hosting provider and ask them about it, it should be a quick task for them.
    The images still work on the server, when you go to http - itís just the https where you canít see them.

  6. #6
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    And do you replace the urls in your database with something like https://wordpress.org/plugins-wp/better-search-replace/ when you switch to https?

  7. #7
    Junior Member
    Join Date
    Dec 2015
    Posts
    8
    Quote Originally Posted by Ante View Post
    And do you replace the urls in your database with something like https://wordpress.org/plugins-wp/better-search-replace/ when you switch to https?
    I'm confused... I didn't "switch to https" just added an SSL so I could take credit cards - so now my site loads both under http and https. I want the images to appear on BOTH http and https.... seems that would be possible if the portfolio section used protocol-relative URLs for the images, right?

    The problem seems to have to do with the fact that the portfolio is loaded dynamically via JavaScript, and you canít cross from https down to http using JavaScript (or all banks would lose all their money instantly).

    Is there any way you could un-hard-code the instances of ďhttp" in the theme to make that work?

  8. #8
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Why do you want to have both http and https versions available? It makes no sense to keep the http since https is available to you. Not sure how Google will look at that either, might flag it as a duplicate content (since same content is available on two versions of the url).