queue  20
support
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: blog gallery - navigation arrows disappear

  1. #1

    blog gallery - navigation arrows disappear

    Apart from still being unreasonably slow, I've discovered a fresh issue: Go to my blog post (gallery) http://www.ukcameraman.co.uk/behind-...nce-unchained/ on safari or iPhone 6s (my set up, others untested), the first couple of pictures (portrait) show up fine, but when the first landscape picture appears, the white arrows disappear against the white background. The images are not responsive on safari either, and I need to scroll up and down to see all of the portrait ones.

    Your help would be appreciated.

  2. #2
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hello, apologies for the late reply.

    Please go to theme folder/js and open blog.js file

    On line 5, before
    Code:
    auto: false,
    add this:
    Code:
    adaptiveHeight: true,
    That should adjust the height of the slider to the images height so you should not have the arrows not displaying problem.

  3. #3
    Thank you for getting back to me. I have set up a child theme. Do I just need to copy the blog.js folder from magnum/js to magnum-child before I make the change you mention?

  4. #4
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hi,

    this will not work, you can only override the php template files by copying them over to the child theme. You will have to modify the js file in the original theme folder.

  5. #5
    Ok thanks. So therefore if there are any updates I will need to remember to do this again, I presume?

  6. #6
    Hi,

    I tried this and it isn't working unfortunately.

    the code now looks like this:

    $(window).load(function() {

    // Featured post slider
    $('.featured-post-slider').bxSlider({
    adaptiveHeight: true,
    auto: false,
    mode: 'horizontal',
    pager: false,
    controls: true,
    nextText: '',
    prevText: ''
    });

    });


    // FitVids
    $(".post-media").fitVids();

  7. #7
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hi,

    you need to set JS Compression to No under Theme Options -> Advanced.

  8. #8
    This still isn't working.

  9. #9
    Can someone please sort this out? I've done everything you told me to do, and the gallery still isn't working.

    I first posted this issue 2 months ago! This response time for support for a malfunctioning product is simply not good enough!!!!!

  10. #10
    Hello? Hello? Is there anybody there? Whats the point in having a slider gallery if the arrows disappear when the aspect ratio changes? Can this really be so hard to figure out? Just give me fecking black arrows or something, I don't care. I've gone past the point of caring what the thing looks like, I just want people to see that there are more photos to be seen.

    Unlike the arrows, I'm not going away, so please try to sort this out. It's coming up to 3 months since I first raised this issue, and a month and a half since you last suggested something.