queue  41
support
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Magic-line problem. Works only with main menu pages.

  1. #1
    Junior Member
    Join Date
    Feb 2015
    Posts
    14

    Magic-line problem. Works only with main menu pages.

    Hi,

    I have problem with a magic-line in my theme. I'm working on my new page www.bajkadwa.pl and I have no idea why the magic-line under menu items works correctly only on that pages which are connected to the main menu. If it is new page without menu connection magic-line doesn’t move at all. It is standing still under the first menu item. Only the short part of white line which should float under all items and follow mouse cursor. Could you help me to solve this problem this is very nice element of FORM theme and I don’t won’t to resign from this functionality

    Thanks a lot
    marco

    BTW. Could You tell me why my admin panel doesn’t have advanced functions of customization, as it described in manual? I don’t have for example Widget Areas, Auto Update, Custom Thumb Cropping etc. Is it a budget version or something differrent?
    Last edited by marcooo_; 02-27-2015 at 15:05.

  2. #2
    Support Anand's Avatar
    Join Date
    Jan 2014
    Posts
    9,896
    Hi,

    Can you please provide me with a link to the page where the magic line isn't working and I'll check it out.

    Please provide us with you login details as explained below and I'll take a look as to why the Widget Areas, etc aren't showing on your site.

    Post your admin login details in this thread so we can login to your WordPress installation and investigate the issue via the admin. You can post this information privately in this thread by wrapping the info inside a "Hide" tag as follows:

    Simply write your information into the post body as you would normally do. Then place the opening hide tag before your info, like this:

    [hide]

    Then place the closing hide tag after your private info, like this:

    [/hide]

    All info contained inside the hide tags will only be visible to forum staff

    Here is what you would type in your post:

    [hide]
    
    url:       http://yoursite.com/wp-admin
    username:  admin
    password:  yourpass
    
    [/hide]

  3. #3
    Junior Member
    Join Date
    Feb 2015
    Posts
    14
    Hi,

    Every page which isn't connected with menu in admin panel works whithout magic line. For example page with first post. http://bajkadwa.pl/?p=338

    ** Hidden Content: You don't have sufficient privileges to see this hidden data **


    thanks for help

    marco

  4. #4
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hi,
    add this to your Custom CSS field in Theme Options panel:
    Code:
    #magic-line {
    padding: 0;
    }
    That should remove the magic line where it's not supposed to be.

    About the features mentioned in the documentation, I apologize for that, we use the same documentation template for all of our themes so there might me some features missing. For example, we removed auto-update for now as it stopped working with the recent Envato API changes.

  5. #5
    Junior Member
    Join Date
    Feb 2015
    Posts
    14
    Hi Ante

    Your advice helped me, but it works in the wrong direction I'd rather expected that everywhere the magic-line will be working in the same way (following mouse cursor, not desappear), because in that theme, despite the cursor which we can see, we don't know which one menu button is in active field. Magic-line helps us to see that. It is important because that page is preparing also to visual impaired people who we have in our project. Can you invert this functionality in two magic line in custom css? I would be greatfull.

    Thanks
    marco

  6. #6
    Lead Support Ante's Avatar
    Join Date
    Oct 2012
    Posts
    16,930
    Hi marco,

    sorry, I somehow missed your reply.

    Do you still need help with this? I just tested your navigation and it seems to me magic line is functioning the way you wanted it.

  7. #7
    Junior Member
    Join Date
    Feb 2015
    Posts
    14
    Hi Ante,

    If you be so kind, it would be great. The issue is still actual. The problem appears only on that pages which are not connected with main menu. When you go one level deeper than you see that magic line has gone away. For example when you want to look at single post page, first one http://bajkabezbarier.pl/?p=711. Every page which is connected with menu shows magic line properly, every which is only single post page - doesn't.

    thanks a lot
    marco

    ps. there is a replay in previous thread (with slider) please look at it.

  8. #8
    Junior Member
    Join Date
    Aug 2016
    Posts
    8
    Hi, same problem here:

    http://oftalpharma.it/wp2016

    Click on "Prodotti" and then in the first product "Blefavis salviette", the "magic-line" stay on the left of the nav menu, and not below the "Prodotti" as I expected.

    Someone can help me please?

    Thank you, regards,
    Gianfranco
    Last edited by bulletta; 08-17-2016 at 14:08. Reason: I've added the subscription

  9. #9
    Administrator Donagh's Avatar
    Join Date
    Aug 2011
    Posts
    2,078
    Hi, Have you tried the padding css solution posted above by my colleague? Paste the snippet into the Custom CSS field in your Theme Options panel.

  10. #10
    Junior Member
    Join Date
    Aug 2016
    Posts
    8
    Quote Originally Posted by Donagh View Post
    Hi, Have you tried the padding css solution posted above by my colleague? Paste the snippet into the Custom CSS field in your Theme Options panel.
    Hi Donagh,
    thank you for your answer.
    Yes, I've tried the padding solution, and line simply disappears. In my opinion, this is just a workaround, the best solution would be to show the line below the parent menu voice ("Prodotti", in this case), do you agree?